Aller au contenu
Emu Nova Forums
Invité Bio

[VBALINK] Jouer en réseau Pokémon Saphir

Messages recommandés

Invité Bio

Salutations,

Nous voulions jouer avec un ami à Pokemon Saphir (lui) et Rubis (moi) afin de pouvoir faire des combats et des échanges.

La seule solution qui nous est apparue, compte tenu de la distance qui nous sépare (environ 500km), est d'utiliser VBA Link via Hamachi. Pas trop de problème quant à la connexion car a priori tout fonctionne de ce côté-ci.

Le problème se pose dans le centre pokémon lorsque nous connectons nos consoles émulées l'une à l'autre : la vitesse du jeu chute subitement vers les 15% (voire moins).

Impossible donc, vous le comprendrez, de jouer dans des conditons pareilles.

Notre configuration VBA Link si besoin est :

- Frame Skip 2

- Aucun Throttle

- Vsync activé avec DDraw Use VideMmemory et DDraw Triple Buffering (D3D Bilinear, GL Bilinear, GL Quads)

- Emulator : Synchronize (testé avec et sans), Pause when inactive window (testé avec et sans), Automatic IPS Patching, Real Time Clock (testé avec et sans), PNG Format

- Son à 44Khz

- Gameboy Automatic (testé avec d'autres formats) en Real Color

Wala donc si vous avez des solutions parce qu'on a passé quasi 3 heures dessus sans trouver de solutions.

Merci d'avance !

Ps : On a aussi essayé de se connecter directement l'un à l'autre avec notre IP mais cela ne fonctionne pas. De toute façon je pense que ce n'est pas la connexion qui est en cause puisque cela fonctionne très bien via Hamachi et que c'est surtout l'émulation qui freeze subitement dès que l'on parle à cette brave dame à l'étage.

Partager ce message


Lien à poster
Partager sur d’autres sites

En passant par Hamachi tu va avoir un ping assez merdique (en tout cas, quand je m'en servait, c'était le cas). Pour gagner du temps de latence (et donc d'émulation), il faut passer directement par vos IP, mais comme tu l'as dit cela ne marche pas. C'est sans doute du au fait que vous avez tout les deux des box (livebox, freebox, xbox etc...) et qu'elles incluent par défaut un pare feu. Essaye d'aller dans la config de ta box et dans son pare-feu ouvre le/les ports que vous utilisez. Veille aussi à rediriger les connexions entrantes vers ta machine, seulement pour le port concerné. La ça devrait marcher en direct. Si tu veux savoir comment faire exactement cette manipulation sur ta box notre ami google t'y aidera.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement

×
×
  • Créer...