Aller au contenu
Emu Nova Forums
Invité Mornaloce

Problème pcsx2 et FFX

Messages recommandés

Invité Mornaloce

Bonsoir à tous,

Voilà je vous écris car je tente depuis quelques jours de jouer à FFX avec l'émulateur pcsx2 mais la plus part du temps le je tourne entre 20 et 30fps ce qui est assez lent. J'ai cherché un peu partout en essayant plusieurs version de l'émulateur : pcsx2 0.9.8, 0.9.9 et 1.0.0, plusieurs configurations et plusieurs bios différents sans succès. J'ai donc regardé si les config de mon PC étaient suffisantes mais j'ai pas trouvé grand chose là dessus sachant que selon le jeu la config requise n'est pas la même. J'aimerais donc avoir votre avis si jamais vous avez réussi à faire tourner FFX avec une config proche de la mienne. Voici ma config :

- OS : Windows 7,

- Résolution Ecran : 1920x1080,

- Processeur : QuadCore Intel Core i7-2630QM 2.00GHz,

- Carte Graphique : NVidia GeForce GTX 560M,

- Ram : 8Go

Mon jeu est un iso version PAL.

Je pensais que ça pouvait venir de mon processeur qui n'ai peut-être pas assez puissant mais il n'utilise que 30% de sa capacité quand le jeu tourne.

Merci d'avance de votre aide.

Cordialement,

Mornaloce

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca vient peut-être de ta carte graphique, je sais pas trop ce que ça vaut une 560M... :hm:

Sinon quelle est ta config (quels plugins et quelle config) ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je n'ai "qu'une petite HD 5750 et un core i5" et je le fais tourner sans trop de souci. Il y a peut-être deux trois points à vérifier : tu peux regarder du côté de la frame limit (si elle est déjà calée sur 50 ou 60 fps, désactive-la pour voir si ça change qqch), et surtout, vérifie que le multithread est activé. Si ton CPU ne tourne qu'à 30%, c'est peut-être qu'il n'utilise qu'un coeur.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité Mornaloce

Bon j'ai trouvé une config pas trop mal. Le jeu tourne entre 30 et 40 fps. En theory ma carte graphique est largement suffisante il me semble. Par contre j'ai pas réussi à trouvé pour le multithread.

Pour ma config pcsx2 0.9.8 :

- GS : GSdx 4600 (MSVC 15.00, SSE41) 0.1.16

- Renderer : Direct3D11 (Hardware)

- Interlacing : None

- D3D : Custon Resolution 1024x1024

- Texture filtering : case remplie

- Allow 8-bit-textures : coché

- PAD : LilyPad svn (r4510) 0.10.0

- SPU2 : SPU2-X r4600m 1.4.0

"Use default setting" : décoché

Bios : Europe v1.60

EE/IOP : Recompiler pour les 2

- Round Mode : Chop/Zero

- Clamping Mode : Normal

VUs : microVU Recompiler pour les 2

- Round Mode : Chop/Zero

- Clamping Mode : Normal

GS :

- Framelimiter :

- Base : 100%

- Slow : 50%

- Turbo : 200%

- Frame Skipping : disabled

GS Window

- Aspect Ration : 4:3

- Custon Window Size : 640x480

Speedhacks

- EE Cyclerate : 1

- VU Cycle Stealing : 0

- Enable INTC Spin Detection

- Enable Wait Loop Detection

- mVU Flag Hack

- mVU Block Hack

Game Fixes

- FFX videos fix

Cordialement,

Mornaloce

Partager ce message


Lien à poster
Partager sur d’autres sites

Par contre j'ai pas réussi à trouvé pour le multithread.

C'est dans la partie Speedhack, tu dois avoir une case, décochée de base, qui parle de multi-threaded VU. Sinon, tu peux aussi regarder si tu obtiens de meilleurs résultats en passant du recompileur à l'interpreteur, dans l'ordre en testant pour l'Emotion Engine et l'IOP, puis pour les microVUs.

Tu peux encore basculer sur un renderer inférieur à Direct3D 11, des fois que ta carte ne serait pas compatible (mais j'en doute).

Tu peux vérifier si le hack vidéo (FFX video fix) ne fait pas ramer ton jeu (mais si tu décoches, t'auras des FMV toutes pourries).

Tu peux aussi tenter un peu de frameskipping, mais le résultat ne sera sans doute pas très probant.

Tu peux enfin jouer avec tous les speedhacks, en cochant quasiment tout (tout ce qui est recommandé au moins) et en poussant les potards vers la droite, au risque de subir des plantages.

Et si rien de tout cela ne fonctionne, tu peux tener la prière à St René d'Angoumois, patron des cafetières entartrées et des chiens d'aveugle.

Ceci étant dit, ton problème est d'autant plus étrange que tu sembles avoir une grosse config et que PCSX2 est naturellement optimisé, même avec les réglages de base, pour faire tourner FFX (il a été développé pour ça, à la base). Tu n'aurais pas une appli qui tournerait en fond de tâche, un truc bien gourmand genre un pare-feu ou un anti-virus ou d'autres trucs avec des tirets au milieu (porte-manteaux, pieds-paquet, gratte-ciel, etc.) ? Parce qu'au bout d'un moment, on peut accuser PCSX2 de tous les maux, mais s'il a pas de mémoire dispo, il peut pas faire grand-chose.

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est vrai que c'est assez bizarre, j'ai une config quasiment similaire à la tienne:

Core I7 2670QM (2.20Ghz à 3.1)

GTX 560M

10 Go de ram

Il tourne au poil chez moi le FFX en 1920x1080 et en X2 scaling donc je vois pas d'où pourrait venir le souci.

As tu fixé la taille de ton swap? (Swap=fichier d'échange windows, passé les 8Go de ram tu peux le fixer à 1023-1024 mo).

http://imageshack.us.../ffxtest01.png/

Pour ce qui est de ma config j'ai quasiment tout laissé par défaut sauf le son et la vidéo je te poste les liens pour que tu t'en fasses une idée.

http://img3.imagesha...confpcsx201.png

http://img35.imagesh...confpcsx202.png

http://img404.images...confpcsx203.png

http://img515.images...confpcsx204.png

http://img812.images...confpcsx206.png

http://img6.imagesha...confpcsx205.png

http://img211.images...confpcsx207.png

http://img254.images...confpcsx208.png

http://img855.images...confpcsx209.png

http://img801.images...confpcsx210.png

Concernant DirectX je ne saurai trop te conseiller de rester en 3D11 hardware( ça utilise plus ta carte graph que le processeur) c'est le rendu le plus prèçis et le plus rapide oublies donc le directX9, sans compter que ta carte graphique le supporte pleinement^^. Question à la con: as tu mis à jour ton driver graphique? On est en 301.42 si ma mémoire est bonne.

Modifié par VEGETO2

Partager ce message


Lien à poster
Partager sur d’autres sites

Il tourne au poil chez moi le FFX en 19020x1080

Wow ! C'est plus du widescreen à ce niveau là, c'est carrément du cinémascope ! :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Lol, bah en fait je joue en full screen, j'aime pas les modes fenêtrés en général. :siffle: Et comme sa config est quasi identique à la mienne il devrait pouvoir faire pareil je pense.

Partager ce message


Lien à poster
Partager sur d’autres sites

N'empêche que du 19020x1080 (ratio 17,61:1) c'est plus que du cinémascope (ratio 2,39:1) ! :delire:

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité Mornaloce

C'est dans la partie Speedhack, tu dois avoir une case, décochée de base, qui parle de multi-threaded VU.

Sur ma version de l'émulateur il n'est pas marqué explicitement "multithread" mais grâce aux screenshot de Vegeto2 j'ai pu voir à quelle case ça correspondait et c'est effectivement coché.

Sinon, tu peux aussi regarder si tu obtiens de meilleurs résultats en passant du recompileur à l'interpreteur, dans l'ordre en testant pour l'Emotion Engine et l'IOP, puis pour les microVUs.

Testé mais ça ne change rien voir ça devient pire.

Tu peux encore basculer sur un renderer inférieur à Direct3D 11, des fois que ta carte ne serait pas compatible (mais j'en doute).

Ma carte graphique supporte DirectX11 y a pas de problèmes de ce côté là. Mais j'avais déjà testé avec Direct3D9 quand même sans résultat apparant.

Tu peux vérifier si le hack vidéo (FFX video fix) ne fait pas ramer ton jeu (mais si tu décoches, t'auras des FMV toutes pourries).

Testé mais pas de meilleurs résultats non plus.

Tu peux aussi tenter un peu de frameskipping, mais le résultat ne sera sans doute pas très probant.

Ca j'y connais rien du tout je l'ai juste activé en gardant les paramètres par défaut et j'ai carrément plus d'affichage.

Tu peux enfin jouer avec tous les speedhacks, en cochant quasiment tout (tout ce qui est recommandé au moins) et en poussant les potards vers la droite, au risque de subir des plantages.

Tout est déjà coché c'est ce qui m'a fait monté entre 30 et 40fps au lieu d'entre 20 et 30fps.

Tu n'aurais pas une appli qui tournerait en fond de tâche, un truc bien gourmand genre un pare-feu ou un anti-virus ou d'autres trucs avec des tirets au milieu (porte-manteaux, pieds-paquet, gratte-ciel, etc.) ? Parce qu'au bout d'un moment, on peut accuser PCSX2 de tous les maux, mais s'il a pas de mémoire dispo, il peut pas faire grand-chose.

Rien du tout. Voilà ce que ça donne en jeu (avec les ressources prises sur PC). A savoir que l'à j'en suis au début dans les ruines où je dois faire un feu.

http://geshacimak.us.../capture2y.png/

Dans le menu en revanche j'ai bien du 50fps. En fait plus il y a d'éléments affiché à l'écran mois j'ai de fps (ce qui est logique).

http://imageshack.us...capture3te.png/

Et dans les pseudo vidéo ça rame aussi :

http://imageshack.us.../capture4t.png/

J'ai essayé de mettre les même config que VEGETO2 mais sans succès. Il semblerai qu'on ai pas les même versions de plugins en revanche :

http://imageshack.us...ettingsvus.png/

http://imageshack.us...ingsspeedh.png/

http://imageshack.us...settingsgs.png/

http://imageshack.us...ingsgswind.png/

http://imageshack.us...ingsgamefi.png/

http://imageshack.us.../capture9q.png/

http://imageshack.us.../capture8i.png/

http://imageshack.us...capture7eu.png/

http://imageshack.us.../capture6s.png/

http://imageshack.us.../capture5j.png/

Partager ce message


Lien à poster
Partager sur d’autres sites

M'en fous un peu :jedi: du moment que le jeu est beau :lol: . Et diantre, qu'est ce qu'il est beau avec ces réglages :rolleyes: .

Partager ce message


Lien à poster
Partager sur d’autres sites

Non mais c'est juste le 19020 au lieu de 1920 qui l'a fait tiquer, hein.

Bon j'avoue, là j'ai plus d'idées. Je passe la main.

Partager ce message


Lien à poster
Partager sur d’autres sites

Lol j'avais pas fait gaffe, mais bon vous aviez compris je joue en 1920 pas en 19020. ^^ Alors là moi aussi je sèche. As tu skype? Je pourrais essayer de te filer ma version de PCSX2 toute configurée et tu essayerais parce que là tu es censé le faire tourner comme moi. As tu mis à jour ta carte graphique (bien que ça tournait bien chez moi dès l'achat du pc).

Modifié par VEGETO2

Partager ce message


Lien à poster
Partager sur d’autres sites

Non mais c'est juste le 19020 au lieu de 1920 qui l'a fait tiquer, hein.

Voilà. C'est tout ce que j'avais à dire.

Sur ce, je m'en vais et je rentre à ma maison !

Partager ce message


Lien à poster
Partager sur d’autres sites

Mdr, ok ok je me suis trompé. Ça arrive les erreurs de saisies hein?. :jedi: Question con mec as tu installé tous les directX et les C++ visual? C'est vraiment zarbe que ça rame chez toi, tu devrais même pas avoir besoin du speedhack. Question système vu la bête que t'as, as tu partitionné ton disque dur? Une partition système et une partition jeux? As tu fixé la taille de ton fichier d'échange?

Modifié par VEGETO2

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui les pilotes de ma carte graphique sont à jour. Pour ce qui est des directX 'est bien installé, j'ai la version 11. Quand à visual C++ je suis pas sure qu'il soit installé.

Mes disques durs sont partitionnés tout les 2 et j'ai effectivement une partition spécial pour mes jeux. Pour mon fichier d'échange j'ai pas bien compris de quoi tu parlais.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bah le fichier d'échange est un système mis en place par Windows pour générer de la mémoire virtuelle en prenant de l'espace disque. Exemple: 1Go de disque dur= 1Go de ram. Mais vu que tu as 8 Go de ram, il est carrément conseillé de le limiter vu qu'il puise sur le disque dur comme un couillon (oui oui bienvenue chez Windows :siffle: ) alors que toute la ram disponible n'est pas utilisée. Donc cela cause de gros accès au disque dur pour les émulateurs ce qui pourrait être la cause de ton ralentissement. Bah en fait je t'ai demandé plus haut si tu avais Skype parce que je t'avoue que de régler ce genre de souci à distance c'est un peu chaud. Mais au vu de ta conf FFX DOIT passer. Donc si tu possèdes Skype fais le moi savoir comme ça je pourrais t'aider de vive voix. :class:

Modifié par VEGETO2

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est possible qu'il émule en software ? Ca expliquerai la lenteur du truc...

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité Mornaloce

C'est possible qu'il émule en software ? Ca expliquerai la lenteur du truc...

Non non link83 j'émule bien en Hardware, regarde les screenshot de ma config et tu verras (c'est le 3° lien en partant du bas).

Donc si tu possèdes Skype fais le moi savoir comme ça je pourrais t'aider de vive voix. :class:

Je possède bien skype. Mais là je suis au boulot :P donc je t'enverrai mon identifiant par mp plus tard. (si je trouve comment on fait pour envoyer un mp sur ce site xD)

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok pas de soucis, bah le software c'est pas terrible; mais vu ses screens il est en hardware. Mais c'est vraiment zarbe que ça rame, je vois vraiment pas où est l'erreur.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité Mornaloce

Ba toute façon j'ai toujours été maudit avec les PC moi. J'ai toujours des trucs qui marchent pas ou mal alors que sur les PC d'autres potes ça fonctionne parfaitement avec des config équivalents voir moins bien ^^

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok c'est bon apparement c'était la version qui foirait. J'ai pris une autres et ça passe plutôt bien. En tout cas merci à vous de m'avoir aidé.

Modifié par Mornaloce

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok bah c'est cool, un problème de plugins sûrement. J'ai vu que t'avais la version qui s'installe, moi j'ai la version à dezipper seulement c'est peut être ça aussi. Enfin content d'avoir pu t'aider en quelque sorte. :class:

Partager ce message


Lien à poster
Partager sur d’autres sites

Ouai c'est possible que ce soit ça aussi enfin bon. Au fait juste pour savoir, est-ce que tu as déjà essayé de faire tourné FFXII sur l'emulateur ? Si oui, ça à fonctionné ? Avec ma nouvelle version j'arrive à faire fonctionné FFX et KH1 sans trop de problèmes. En revanche KH2 rame un peu et FFXII rame beaucoup et FF Dirge of Cerberus au moins autant. (oui j'adore les Square Enix ^^). En fait j'ai peut-être as tant réglé le problème que ça xD

Partager ce message


Lien à poster
Partager sur d’autres sites

Bah FFXII tourne au poil pour moi avec la même config xd. :jedi: Cependant j'ai un ralentissement pendant le myste de Basch et ses lames ardentes sinon globalement le jeu tourne bien et j'arrive à la fin là.^^:class:

http://imageshack.us/f/88/ffxiitest01.png/

Moi aussi j'aime les Square Enix :D bienvenue au club xd.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement

×
×
  • Créer...