Aller au contenu
Emu Nova Forums
Windsor75

Winuaex, Winuae et WHDLoad

Messages recommandés

Bonjour,

Je me sers de ma XBox pour faire de l'émulation Amiga, via WinuaeX. Je fonctionnais "à l'ancienne", avec des images de disquettes, mais j'ai découvert la possibilité d'émuler un HDD, et donc des chargements plus rapides et moins de problèmes de config avec WHDLoad.

Avant de faire tourner ça sur XBox, j'ai voulu commencer par essayer sur PC. J'ai fait quelques recherches sur le net pour des tutos, et j'ai essayé de suivre celui-ci :

http://www.amigachapterone.com/amiga/tutor...tutorat_whd.htm

J'arrive à faire ce qu'ils disent, mais avec les deux jeux que j'ai essayés (téléchargés depuis http://www.whdload.de/), à savoir Vroom et Stunt Car Racer, j'ai des problèmes :

- Vroom me sort le message "Your installer is outdated" et m'invite à télécharger un fichier lha, ce que je fais mais où le mettre ensuite ?

- Stunt Car Racer me demande d'insérer la disquette du jeu pour l'install

Bref je galère pour lancer ça sur PC, ce qui me décourage un peu, et me fait craindre le pire sur XBox...

Donc je me tourne vers vous et vous demande l'aide pour me guider dans les méandres de cette émulation.

Merci par avance :diable:

Partager ce message


Lien à poster
Partager sur d’autres sites

alors, alors....

mmm, 1ere chose au niveau du message "Your installer is outdated", cela vient du fait que tu utilises un pack pret à l'emploi incluant une ancienne version de Whdload (qui est lui-meme un programme à part entière installé à l'intérieur de ce pack).

il faudrait une mise à jour ou une reinstall de Whdload, mais là je passe la main à mes confrères sur ce sujet... je ne me souviens plus vraiment de la procédure.

S'agissant des jeux, ou plutôt soi-disant jeux que tu as téléchargé, ce que tu trouves en fait sur http://www.whdload.de ce sont des sortes de petits exécutables qui servent à lancer le jeu nommé mais seulement si tu possèdes déjà ce jeu sous forme de disquettes originales.

la solution pour cela c'est de telecharger le jeu en version WHD configuré directement, ça se passe ici

Stunt car racer WHD http://www.whdownload.com/games.php?name=s...ort=0&dir=0

Vroom WHD http://www.whdownload.com/games.php?name=v...ort=0&dir=0

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est étrange, dernièrement Titan a remis intégralement son pack a jour. Est tu sur d'avoir la dernière version du pack ?

Sinon attention aussi, comme Anar l'a dit, sur Whdload.de il n'y a pas de jeux a télécharger, uniquement des patchs. Tu peut par contre retrouvé des jeux pré-patché sur les sites suivants :

En détail : http://www.whdownload.com/

En gros : http://www.guildserver.co.uk/kgwhd/

Tu as également la possibilité d'utiliser ce dossier :

http://www.amigafantasy.com/dossiersWhdload.htm

http://www.amigafantasy.com/dossiersJeuxWhdload.htm

Le système est très épuré mais a jour.

Modifié par Human Ktulu

Partager ce message


Lien à poster
Partager sur d’autres sites
oh derniere chose, ce tuto t'en dira plus sur la manoeuvre d'installation de whdload!

http://insertdisk2.free.fr/index.php?page=11&id=14

Ce tuto est plutôt destiné aux possesseurs d'Amiga j'ai l'impression. Ca commence par la copie de fichiers sur le disque dur d'un Amiga :diable:

C'est étrange, dernièrement Titan a remis intégralement son pack a jour. Est tu sur d'avoir la dernière version du pack ?

Ben il semblerait que non mdr

Tu as également la possibilité d'utiliser ce dossier :

http://www.amigafantasy.com/dossiersWhdload.htm

http://www.amigafantasy.com/dossiersJeuxWhdload.htm

Le système est très épuré mais a jour.

J'ai essayé ce tuto, mais quand je lance l'émulateur, celui-ci me dit "Ne peut pas charger la ROM Kickstart, tentative de remplacement de la ROM système". Quand je clique sur Ok, j'ai un autre message qui me dit "Vous avez besoin d'une disquette (fichier image) dans l'emplacement DF0 : pour utiliser le remplacement de la ROM système", alors que j'ai bien les fichiers kickstart qui étaient avec l'émulateur.

Bref je galère, et j'ai pas encore attaqué le passage à la XBox...

Partager ce message


Lien à poster
Partager sur d’autres sites

alors: une bonne chose pour toi: AMIGASYS. http://amigasys.extra.hu/xbox.html

Ils ont creer un DD Amiga pour XBOX. Tu copies sur le DD de ton PC, tu passes par Winuae, tu installes dessus les jeux WHDLOAD et la derniere mouture de WHDLoad.

Il te faudra les d7 de workbenck 30! Elles sont demandées pour des raisons legales.

Franchement, c'est l'idéal. C'est ce que j'ai pour ma xbox et c'est bcp plus fun.

Par contre, j'suis alle à l'essenteiel, comme j'ai fait la manip depuis kektemps, j'ai zappé des trucs je pense.

Modifié par DoubleMG

Partager ce message


Lien à poster
Partager sur d’autres sites
alors: une bonne chose pour toi: AMIGASYS. http://amigasys.extra.hu/xbox.html

Ils ont creer un DD Amiga pour XBOX. Tu copies sur le DD de ton PC, tu passes par Winuae, tu installes dessus les jeux WHDLOAD et la derniere mouture de WHDLoad.

Il te faudra les d7 de workbenck 30! Elles sont demandées pour des raisons legales.

Franchement, c'est l'idéal. C'est ce que j'ai pour ma xbox et c'est bcp plus fun.

Par contre, j'suis alle à l'essenteiel, comme j'ai fait la manip depuis kektemps, j'ai zappé des trucs je pense.

Euh question bête : comment tu "installes" les jeux Whdload et Whdload ? En ajoutant depuis le menu "Disques durs" de Winuae ? J'ai l'impression que ça sert juste au profil qu'on lance, mais est-ce que ça va le "copier" dans l'image du DD ?

Merci (et désolé pour les questions de noob :diable: )

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis passé par un repertoire PC reconnu par WInuae et donc sous le Workbench.

Apres, sous ton WB, il y a ton DD et ton rep, tu les ouvres et tu les copies par glisser deposer.

Simplement, dans Winuae, Disques durs, n'oublie pas d'y inclure ton DD et ton repertoire.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, la bonne nouvelle c'est que je crois que je commence à capter le truc...

On se sert de Winuae pour émuler le WB et copier dans l'image HDD les jeux Whdload, ainsi que Whdload. Cette image part après sur la XBox.

Pour les jeux pas de pb, par contre la version de Whdload que j'ai téléchargée depuis whdload.de est une version "install" Amiga, que j'essaie d'installer depuis le Workbench. Mais ça ne marche pas, je récolte le message "Unable to open your tool 'Installer'". But why ?

Dans l'image HDD "spéciale XBox", il y a des install (AmigaSysInstall) que j'ai essayé, pour voir si ça venait de là, mais ça foire au bout d'un moment, ça me dit "Please insert Extras 3.0/3.1 disk into DF1:" et impossible de passer ça. Mais si ça se trouve ça sert à rien.

Bref, une fois encore j'ai besoin de vos lumières...

(Je ne désespère pas, Je ne désespère pas...)

Partager ce message


Lien à poster
Partager sur d’autres sites

Oye, la galère :alien:

Bon effectivement il est mieux d'avoir quelques bases sur le workbench ça aide. Mais bon on est là pour aider :merlin:

Bon, "Unable to open your tool 'Installer'" ça veux dire que le programme d'installation ne peut s'exécuter parce que il manque un composant du workbench : l'outil "Installer". Tu peut le télécharger ici : http://aminet.net/package/util/misc/Installer-43_3

Pour la décompression de l'archive il me semble que winrar et izarc prend en charge le format lha. Pour l'installation du composant (pas de panique !) il suffit de copier le fichier nommé "installer" dans le dossier "C" du workbench.

J'ai essayé ce tuto, mais quand je lance l'émulateur, celui-ci me dit "Ne peut pas charger la ROM Kickstart, tentative de remplacement de la ROM système". Quand je clique sur Ok, j'ai un autre message qui me dit "Vous avez besoin d'une disquette (fichier image) dans l'emplacement DF0 : pour utiliser le remplacement de la ROM système", alors que j'ai bien les fichiers kickstart qui étaient avec l'émulateur.
A tout les coups WinUAE c'est lancé avec le mode "Quickstart mode", cette saloperie est activé par défaut. Dans l'onglet "Quickstart" en bas de page il faut décocher la case "lunch with quickstart mode". Il n'y a rien a sauvegardé, cet état est conservé dans le registre d'état de winbouse (tony willen à abusé sur ce truc). M'enfin, il y en a tout de même qui utilise que ça :gerbe:

Partager ce message


Lien à poster
Partager sur d’autres sites
Oye, la galère :alien:

Bon effectivement il est mieux d'avoir quelques bases sur le workbench ça aide. Mais bon on est là pour aider :merlin:

Merci jap.gif

Bon, "Unable to open your tool 'Installer'" ça veux dire que le programme d'installation ne peut s'exécuter parce que il manque un composant du workbench : l'outil "Installer". Tu peut le télécharger ici : http://aminet.net/package/util/misc/Installer-43_3

Pour la décompression de l'archive il me semble que winrar et izarc prend en charge le format lha. Pour l'installation du composant (pas de panique !) il suffit de copier le fichier nommé "installer" dans le dossier "C" du workbench.

Alors j'ai bien téléchargé ce fichier, décompressé, et j'ouvre le répertoire depuis le WB. Le truc fun c'est que je vois tous les fichiers, sauf "installer", mdr :

loaderamigaii5.th.jpg

Du coup je peux pas le copier sur la racine de C (c'est où au fait la racine de C ? Quand on doublie-clique sur "System" ?

A tout les coups WinUAE c'est lancé avec le mode "Quickstart mode", cette saloperie est activé par défaut. Dans l'onglet "Quickstart" en bas de page il faut décocher la case "lunch with quickstart mode". Il n'y a rien a sauvegardé, cet état est conservé dans le registre d'état de winbouse (tony willen à abusé sur ce truc). M'enfin, il y en a tout de même qui utilise que ça :gerbe:

Effectivement j'avais ce truc de coché. Ca marche mieux sans, merci :)

Partager ce message


Lien à poster
Partager sur d’autres sites
Alors j'ai bien téléchargé ce fichier, décompressé, et j'ouvre le répertoire depuis le WB. Le truc fun c'est que je vois tous les fichiers, sauf "installer", mdr : loaderamigaii5.th.jpg

Du coup je peux pas le copier sur la racine de C (c'est où au fait la racine de C ? Quand on doublie-clique sur "System" ?

Misère. bon courage ! <_<

Bon, je vois sur ton écran que le fichier installer est bien présent dans ton dossier coté PC. Tu ne le vois pas coté Workbench puisque ce fichier ne procède pas d'icone, pour le voir il faut sélectionner la fenêtre, faire click droit et aller dans le menu "Fenêtre" et sélectionner "Montrer" - "Tout les fichiers" (c'est le genre de ptit truc qui montre de billoute n'aurai jamais pensé à ça).

Bref, voila en image :

thumb.jpg

Mais tu peut faire plus simple en réalisant toute cette opération depuis windows, il faut pour cela utiliser des répertoires PC comme disque dur Amiga virtuel. Dans l'onglet "hard drive" de winuae c'est la fonction "ADD DIRECTORY".

Enfin, ce fichier "Installer", il faut le copier dans le dossier "C" du workbench, c'est a dire dans un dossier "non visible" (car sans icone) de la partition systeme qui contient le workbench.

Et non dans la racine C de windows :rolleyes:

Par ailleurs sur amiga les partitions se nomment plutot DH0, DH1, ... mais il n'y a rien de formel.

Bon, je prie le bon dieu en espérant que tu ai compris, au quel cas n'hésite pas à revenir :unsure:

Partager ce message


Lien à poster
Partager sur d’autres sites
Misère. bon courage ! <_<

MDR, à ce rythme c'est plutôt à toi qu'il faut souhaiter ça, vu l'aide que tu es obligé de faire !

Bon, je vois sur ton écran que le fichier installer est bien présent dans ton dossier coté PC. Tu ne le vois pas coté Workbench puisque ce fichier ne procède pas d'icone, pour le voir il faut sélectionner la fenêtre, faire click droit et aller dans le menu "Fenêtre" et sélectionner "Montrer" - "Tout les fichiers" (c'est le genre de ptit truc qui montre de billoute n'aurai jamais pensé à ça).

Bref, voila en image :

thumb.jpg

Non mais jamais de la vie j'aurais cherché ça !!! En tout cas maintenant effectivement je vois le fichier.

Enfin, ce fichier "Installer", il faut le copier dans le dossier "C" du workbench, c'est a dire dans un dossier "non visible" (car sans icone) de la partition systeme qui contient le workbench.

Et non dans la racine C de windows :rolleyes:

Par ailleurs sur amiga les partitions se nomment plutot DH0, DH1, ... mais il n'y a rien de formel.

Bon j'ai réussi à faire la connerie de copier ça sur le C de Windows... Après avoir compris mon erreur, j'ai cherché le C du Workbench. Je pense l'avoir trouvé via un truc qui s'appelle FileMaster. J'ai compris comment copier le fichier mais, car y'en a un sinon ce serait pas drôle, le répertoire est protégé en écriture, et je trouve pas comment le déprotéger, mdr

J'ai tenté "attrib -r dh0" en ligne de commande mais je me suis fait envoyer bouler...

Je suis encore loin de jouer sans les "disquettes" !

Partager ce message


Lien à poster
Partager sur d’autres sites

OK on progresse :class:

Mais vu que l'on utilise pas le même workbench c'est difficile pour moi de suivre tes soucis. Je te propose d'utiliser ce workbench que j'ai mis moi même au point pour ce genre de situation : http://www.amigafantasy.com/jeux/telecharg...ans_cle_whd.zip

Avec ça tu n'a pluqu'a lancer tes whd pré-installés.

Sinon pour répondre a ta question, file master est capable de modifier les paramètres fichier, c'est l'option protect il me semble. Cela dit je suis étonné que cet outil soit présent en lecture seule.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

J'ai essayé rapidement hier soir (pas beaucoup de temps, snif) ton image disque. Déjà un truc que je suppose "pas normal", c'est que, quelle que soit l'image que j'essaie, j'ai toujours une interface moche limite en mode texte, au lieu des belles interfaces graphiques que je peux voir en screenshot.

Ensuite j'ai voulu lancer Vroom, mais il me dit que WHDLoad n'est pas installé, je croyais que c'était le cas. J'ai pas pris le temps d'essayer de l'installer. Par contre j'ai voulu copier Vroom, mais impossible : C est en lecture seule, et l'autre "disque" (je ne me souviens plus du nom) est plein.

J'en viens à me demander si j'utilise aussi le bon Winuae ou la bonne config'...

Personne sur Bordeaux pour me paramétrer tout ce qui faut comme il faut ? mdr...

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut :unsure:

Pour l'interface graphique c'est normal, je n'ai rien installé dans ce sens (c'est ça le mode "normal" ^^ ) pour laisser le choix à l'utilisateur entre différentes solutions. Par contre whd est installé, ça c'est sur ! Tu as bien placer cet HDF en 1ere position ?

Sinon il y aurai quelqu'un sur bordeaux, tu peut le contacter via son site : http://www.b3dgs.com/

Tu peut aussi consulter l'annuaire amiga francophone http://www.annuaire-amiga.org/

http://www.annuaire-amiga.org/index.php?pa...deprecherche=33

Modifié par Human Ktulu

Partager ce message


Lien à poster
Partager sur d’autres sites

MDRRRRRRRRRRRRRRRRRRRRRR les biloutes héhé ,ils suent comme des bodés les collègues là .

Ness, plié en deux.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je hdf de Human fonctionne bien ,tout est bien présent (Whdload et les kickstarts dans Devs ) .Les utilitaires de décompréssion sont bien là (LHA , LZX) le contraire venant de sa part m'aurait bien étonné.

Je passe sur les paramétrages de Winuae .

pour bien s'y retrouver il faut créer deux dossiers sous Windows qui seront affichés sur le bureau du Workbench .Ex:Jeux et TelechargementWhdAmiga .Tu mets ce que tu veux .Ouvrir le dossier jeux et créer un autre dossier ex: GamesA(tu peux en faire d'autres par ordre alphabétique)

Dans Winuae ,menu Hard drives choisir Add directory ,dans le requester Volume Settings cliquer sur path, dès que tu vois (jeux) tu cliques dessus .Dans volume label mettre le mot jeux et dans device name ,tape un nom ex:dossier jeux .Faire la même chose avec téléchargementWhdAmiga .

dans le menu configuration ,Sauvegarde sous un nom ex: MonEmulationPerso

Lance l'émulation

Tu peux aussi afficher ta ou tes partitions PC en cochant dans Hard Drives ,Add Pc Drives AT startup , c'est aussi un moyen assé rapide de s'y retrouver .Seulement attention car on peut éffacer par erreur des fichiers importants .

La suite .

Tu as télécharger des jeux whdload compressés en Lha . .Ouvrir le dossier dédié ou se trouve les jeux. Clique sur un nom ayant l'extension Lha ex:Vroom.lha.Dans le requester qui s'affiche tu avances le curseur devant la phrase et tu tapes

(Voici la phrase que tu dois avoir et rien d'autre avant de cliquer sur ok)

lha e vroom.lha jeux:GamesA

Théoriquement dans le dossier GamesA tu devrais avoir ton répertoire Vroom

Je passe souvent par le disque RAM pour la décompression

Ex:

lha e vroom.lha Ram:

Et ensuite si tout va bien je le Drag and drop dans un dossier dédié

Pour l'interface graphique c'est normal, je n'ai rien installé dans ce sens (c'est ça le mode "normal" wink.gif )

Ben oui , si c'est pour lancer que des jeux ,c'est largement suffisant et en plus ton hdf est rapide. .Perso Je réfléchi pour AmigamerHd ,principalement pour les fichiers systèmes du Workbench (mettre le minimum).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour et merci pour te lancer dans l'aventure "On aide le noob comme on peut !"

J'ai essayé de suivre à la lettre tout ce que tu as écrit.

Tout d'abord première chose : ce que j'ai téléchargé comme jeux est en .zip. Téléchargé depuis whdownload.com (voir 2ème post de ce topic). J'ai bien tenté de dézipper pour repasser au format lha, ce que j'ai réussi à faire. Mais là où je m'étonne, c'est qu'en voulant faire un lha, le WB me sort :

"lha:unknown command

lha failed returncode 10"

Ce qui déjà m'a laissé songeur...

Après je me suis dit que l'important était que dans le WB on voit le répertoire du jeu. Donc sous Windows j'ai dézippé le répertoire. J'ai réussi ensuite sous le WB à le copier sur le deuxième répertoire, mais à l'exécution il me sort "Unable to open your tool 'WHDLoad'" :

wbvd3.th.jpg

Alors que pourtant j'ai bien téléchargé le zip donné par Human Ktulu... Cela pourrait-il venir d'une config de Winuae ?

Partager ce message


Lien à poster
Partager sur d’autres sites

D'aprés ce que je peu voir de ton screen, ce n'est pas SYS3.1 qui a démarré ton systeme mais peut être un adf (je voie la présence d'un adf "Workbench 3.0 grrrr :delire: ) ou un autre hdf.

Pour faire un comparatif sur PC, c'est comme si que tu est sur la disquette d'urgence MS-Dos au lieu d'avoir démarrer ton windows. Bon je sais, les systèmes d'urgence Amiga ça à quand même plus de gueule lool

D'ou ton souci et ta confusion :zorro:

Partager ce message


Lien à poster
Partager sur d’autres sites
D'aprés ce que je peu voir de ton screen, ce n'est pas SYS3.1 qui a démarré ton systeme mais peut être un adf (je voie la présence d'un adf "Workbench 3.0 grrrr :delire: ) ou un autre hdf.

Pour faire un comparatif sur PC, c'est comme si que tu est sur la disquette d'urgence MS-Dos au lieu d'avoir démarrer ton windows. Bon je sais, les systèmes d'urgence Amiga ça à quand même plus de gueule lool

D'ou ton souci et ta confusion :zorro:

Quel flan je fais... J'avais effectivement oublié une disquette dans un lecteur ! En gros comme tu disais je bootais sur DOS sur A: au lieu de Windows sur C:... Ca marche beaucoup mieux maintenant !

J'ai essayé de lancer Vroom, ça me fait un affichage tout naze : ci-dessous le menu de Vroom :

vroomac1.th.jpg

D'ailleurs je trouve que le jeu est lent à lancer, normal ? Peut-être moins lent que sur disquette, mais je voyais ça plus rapide.

Partager ce message


Lien à poster
Partager sur d’autres sites

Chez moi aussi j'ai le même problème avec vroom

faut que je regarde le tooltype

Les jeux en Whdload sont un peu plus lent au démarrage car il faut acheter une key chez l'auteur .Ce key désactive l'affichage du requester .

Partager ce message


Lien à poster
Partager sur d’autres sites

Euh, tente peut être le coup avec Vroom 2 ou Vroom Multiplayer, c'est le même jeu aprés tout :delire:

Perso le premier Vroom m'a aussi toujours posé problème.

Modifié par Human Ktulu

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×